Latest Responses
Username:
Password:
avatar

By ndlsjk

August 18, 2022, 10:15 am

Lost tool database :(

Hey Eldar,

Long time no talk. I had a power outage yesterday and it appears my entire tool database was wiped out. When I try to open HSMA it pops an error that says:

"Error loading your Tool DataBase
'.', hexadecimal value 0x00, is an invalid character, Line 1, position 1.
Please specify a valid location for your Tool Data Base"



I press okay and it brings up a file browser window. I select the user tool database xml file and it gives the same error. If I open the XML file in notepad it is blank. I tried to load the database from the "backups" folder and it was the same.

Is there anything I can do to fix this (I had close to 1000 tools saved with feeds/speeds) or am I out of luck?

Thanks in advance,

Jake

Answers:
cant leave messages here
Pages:(1) [1]
avatar

ndlsjk

August 18, 2022, 10:17 am

Nevermind,

For some reason it was trying to load a tooldb2 instead of the regular tooldb. Got er all fixed up.

Thanks again.

avatar

Eldar Gerfanov

August 18, 2022, 4:47 pm

Hi,

Phew! That was a close one! Please make sure to manually back up your tool database file in a safe place.

tooldb is an older database format. You probably restored an older version of your data base.

When HSMAdvisor opens tooldb file it converts it to tooldb2 and uses the new file instead.

Sometimes backup folder can end up with bad files as well.

© 2009-2022 Eldar Gerfanov. All Rights Reserved.
© 2009 Eldar Gerfanov. Materials on this site are presented as is and are mostly for educational use.

You may freely reproduce information presented herein without any consent from me, provided you include link to this site.
In case when i am not the copyright holder, you may want to contact proper owner of material. Anyway, they are freely available on the Internet.
If you hold the copyright right for any of the materials on this site and want them removed, please contact me here